【安全通报】Apache Druid 远程代码执行漏洞 (CVE-2021-25646)

花屋敷  260天前

image-20210201114538494.png

Apache Druid 是一个开源的分布式数据存储。Druid 的核心设计结合了数据仓库,时间序列数据库和搜索系统的思想,以创建适用于各种用例的高性能实时分析数据库。Druid 将这三个系统中的每个系统的关键特征合并到其接收层,存储格式,查询层和核心体系结构中。

近日,Apache Druid 官方发布安全更新,修复了 Apache Druid 远程代码执行漏洞。由于 Apache Druid 默认情况下缺乏授权认证,攻击者可直接构造恶意请求执行任意代码,控制服务器。建议Apache Druid 用户尽快采取安全措施阻止漏洞攻击。

CVE 编号

CVE-2021-25646

影响范围

  • Apache Druid < 0.20.1

根据目前FOFA系统最新数据(一年内数据),显示全球范围内(title="Apache"&&title="Druid")共有 589 个相关服务对外开放。美国使用数量最多,共有 252 个;中国第二,共有 117 个;英国第三,共有 39 个;印度第四,共有 32 个;爱尔兰第五,共有 31 个。

全球范围内分布情况如下(仅为分布情况,非漏洞影响情况)

image-20210201113820448.png

中国大陆地区北京使用数量最多,共有 14 个;浙江第二,共有 14 个;上海第三,共有 4 个,广东第四,共有 3 个;重庆第五,共有 1 个。

image-20210201113853300.png

Vulfocus靶场环境 

目前 Vulfocus 已经集成 Apache Druid 环境,可通过以下命令进行拉取运行:

docker pull vulfocus/apache_druid-cve_2021_25646:latest docker run -d -P vulfocus/apache_druid-cve_2021_25646

也可使用线上环境 http://vulfocus.fofa.so/ 进行测试。

修复建议

  1. 目前官方已发布漏洞修复版本0.20.1,下载地址:https://druid.apache.org/downloads.html

参考

[1] https://druid.apache.org/

[2] https://m.aliyun.com/doc/article_detail/1060799717.html

白帽汇从事信息安全,专注于安全大数据、企业威胁情报。

公司产品:FOFA-网络空间安全搜索引擎、FOEYE-网络空间检索系统、NOSEC-安全讯息平台。

为您提供:网络空间测绘、企业资产收集、企业威胁情报、应急响应服务。

最新评论

昵称
邮箱
提交评论