【安全通报】Linux DirtyPipe本地权限提升漏洞 (CVE-2022-0847)

AnM1ng  74天前

logo_20220308133248.png (1331×838) (nosec.org)

近日,网络上出现 Linux 下 DirtyPipe 本地权限提升漏洞,任何非特权本地用户可通过此漏洞获取root权限。目前该漏洞PoC已公开,且可能已经被在野利用。

漏洞描述

CVE-2022-0847 是存在于 Linux 内核 5.8 及之后版本中的本地提权漏洞。 攻击者通过利用此漏洞,可覆盖重写任意可读文件中的数据,从而可将普通权限的用户提升到特权 root。 CVE-2022-0847 的漏洞原理类似于 CVE-2016-5195 脏牛漏洞(Dirty Cow),但它更容易被利用。漏洞作者将此漏洞命名为“Dirty Pipe”。

CVE-2022-0847

非特权用户可利用 Linux DirtyPipe本地权限提升漏洞 (CVE-2022-0847)在只读文件中注入或重写数据,从而可将普通用户权限提升至 root权限。

该漏洞CVSS评分:7.8,危害等级:高危

CVE 编号

CVE-2022-0847

FOFA 查询

app=Linux-操作系统

影响范围

5.8 <= Linux 内核版本 < 5.16.11 / 5.15.25 / 5.10

根据目前FOFA系统最新数据(一年内数据),显示全球范围内(app=Linux-操作系统)共有 17,985,571 个相关服务对外开放。中国使用数量最多,共有 4,640,429 个;乌拉圭第二,共有 1,187,196 个;美国第三,共有 1,184,274 个;越南第四,共有 1,035,396 个;台湾(中国)第五,共有 933,038 个。

全球范围内分布情况如下(仅为分布情况,非漏洞影响情况)

mainland.png (957×456) (nosec.org)

中国大陆地区浙江使用数量最多,共有 983,017 个;江苏第二,共有 617,891 个;上海第三,共有 503,084 个;广东第四,共有 363,092 个;北京第五,共有 222,873 个。

mainland.png (957×456) (nosec.org)

修复建议

参考漏洞影响范围,请将Linux升级至以下安全版本。

Linux 内核 >= 5.16.11
Linux 内核 >= 5.15.25
Linux 内核 >= 5.10.102

参考

[1] https://www.bleepingcomputer.com/news/security/new-linux-bug-gives-root-on-all-major-distros-exploit-released/

[2] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=9d2231c5d74e13b2a0546fee6737ee4446017903


白帽汇从事信息安全,专注于安全大数据、企业威胁情报。

公司产品:FOFA-网络空间安全搜索引擎、FOEYE-网络空间检索系统、NOSEC-安全讯息平台。

为您提供:网络空间测绘、企业资产收集、企业威胁情报、应急响应服务。

最新评论

。。。  :  版本发详细一点,5.10复现成功了
74天前 回复
昵称
邮箱
提交评论