【安全通报】STRUTS S2-059/S2-060安全漏洞(CVE-2019-0230/CVE-2019-0233)

花屋敷  43天前

Struts官方发布新的安全通告,公布了2个安全漏洞:S2-059(CVE-2019-0230)是一个潜在的远程代码执行漏洞,S2-060(CVE-2019-0233)是一个拒绝服务漏洞。

image-20200813211821896.png

Apache Struts2框架是一个用于开发Java EE网络应用程序的Web框架。Apache Struts于2020年8月13日披露 S2-059 Struts 远程代码执行漏洞(CVE-2019-0230),在使用某些tag等情况下可能存在OGNL表达式注入漏洞,从而造成远程代码执行,风险极大。

CVE 编号

CVE-2019-0230,CVE-2019-0233

影响范围

  • Apache Struts 2.0.0 - 2.5.20

根据目前FOFA系统最新数据(一年内数据),显示全球范围内(app="struts2")共有 33621302 个相关服务对外开放。美国使用数量最多,共有 2384626个;中国第二,共有 1366619 个;印度第三,共有 431329 个;德国第四,共有 360839 个;巴西第五,共有 347103 个。

全球范围内分布情况如下(仅为分布情况,非漏洞影响情况)

image-20200813210319042.png

中国大陆地区北京使用数量最多,共有 196077 个;上海第二,共有 84381 个;山东第三,共有 40638 个,辽宁第四,共有 24800 个;福建第五,共有 22643 个。

image-20200813210355372.png

漏洞环境——Vulfocus

目前 Vulfocus 已经集成 CVE-2017-9805 等环境,可通过 docker pull vulfocus/struts2-cve_2017_9805 进行拉取运行,可也通过 http://vulfocus.fofa.so/ 进行测试。

image-20200813211024423.png

修复建议

  1. 将Apache Struts框架升级至最新版本。

参考

[1] https://mp.weixin.qq.com/s/sRcP27-y_Ps-YGTZ3Y4uZQ

白帽汇从事信息安全,专注于安全大数据、企业威胁情报。

公司产品:FOFA-网络空间安全搜索引擎、FOEYE-网络空间检索系统、NOSEC-安全讯息平台。

为您提供:网络空间测绘、企业资产收集、企业威胁情报、应急响应服务。

最新评论

你的小迷弟  :  小迷弟前来报道。
43天前 回复
昵称
邮箱
提交评论