Linux Kernel 信息泄漏&权限提升漏洞(CVE-2020-8835)

iso60001  209天前

22.jpg

0x01漏洞简介:

3月31日, 选手Manfred Paul 在Pwn2Own比赛上用于演示Linux内核权限提升的漏洞被CVE收录,漏洞编号为CVE-2020-8835。


此漏洞由于bpf验证系统在Linux内核中没有正确计算某些操作的寄存器限制,导致本地攻击者可以利用此缺陷越界读取机密信息(内核内存)或将用户提升为管理权限。请相关用户采取措施进行防护。

0x02影响版本:

·Linux Kernel 5.4
·Linux Kernel 5.5

0x03漏洞危害:

攻击者利用此漏洞,可实现信息获取与权限提升。

0x04 版本检测:


Linux系统用户可以通过查看版本来判断当前系统是否在受影响范围内查看操作系统版本信息命令如下:


cat /proc/version

0x05官方防护:

受影响用户可通过升级Linux系统内核的方式进行防护,下载链接:
https://github.com/torvalds/linux/releases
Debian bullseye 受影响信息请查阅:
https://security-tracker.debian.org/tracker/CVE-2020-8835
Ubuntu发行版详情信息请查阅:
https://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-8835.html

0x06临时防护措施:

若相关用户暂时无法更新Linux Kernel,可采用发行商提供的缓解措施,通过修改内核参数来对普通用户进行限制。


Ubuntu:
将kernel.unprivileged_bpf_disabled sysctl设置为1
$ sudo sysctl kernel.unprivileged_bpf_disabled=1$ echo kernel.unprivileged_bpf_disabled=1 | \sudo tee /etc/sysctl.d/90-CVE-2020-8835.conf
在使用安全引导的系统上,这个问题也会得到缓解。
Redhat:
sysctl -w kernel.unprivileged_bpf_disabled=1


◆来源:黑白之道

◆本文版权归原作者所有,如有侵权请联系我们及时删除

最新评论

昵称
邮箱
提交评论